Buffer Overflow Affecting libpcap package, versions [,1.9.1)


Severity

Recommended
0.0
medium
0
10

CVSS assessment by Snyk's Security Team. Learn more

Threat Intelligence

EPSS
2.76% (85th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-UNMANAGED-LIBPCAP-2319198
  • published14 Dec 2021
  • disclosed3 Oct 2019
  • creditUnknown

Introduced: 3 Oct 2019

CVE-2019-15161  (opens in a new tab)
CWE-131  (opens in a new tab)

How to fix?

Upgrade libpcap to version 1.9.1 or higher.

Overview

Affected versions of this package are vulnerable to Buffer Overflow rpcapd/daemon.c in libpcap before 1.9.1 mishandles certain length values because of reuse of a variable. This may open up an attack vector involving extra data at the end of a request.

CVSS Base Scores

version 3.1