Improper Input Validation Affecting librsvg package, versions [,2.40.12)


Severity

Recommended
0.0
high
0
10

CVSS assessment by Snyk's Security Team. Learn more

Threat Intelligence

EPSS
2.39% (84th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-UNMANAGED-LIBRSVG-2369970
  • published26 Jan 2022
  • disclosed20 May 2016
  • creditUnknown

Introduced: 20 May 2016

CVE-2015-7558  (opens in a new tab)
CWE-20  (opens in a new tab)

How to fix?

Upgrade librsvg to version 2.40.12 or higher.

Overview

Affected versions of this package are vulnerable to Improper Input Validation librsvg before 2.40.12 allows context-dependent attackers to cause a denial of service (infinite loop, stack consumption, and application crash) via cyclic references in an SVG document.

References

CVSS Base Scores

version 3.1