Symlink Attack Affecting libxfont package, versions [1.0.0,1.5.4)[2.0.0,2.0.3)


Severity

Recommended
0.0
medium
0
10

CVSS assessment by Snyk's Security Team. Learn more

Threat Intelligence

EPSS
0.42% (34th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-UNMANAGED-LIBXFONT-2367887
  • published26 Jan 2022
  • disclosed1 Dec 2017
  • creditUnknown

Introduced: 1 Dec 2017

CVE-2017-16611  (opens in a new tab)
CWE-59  (opens in a new tab)

How to fix?

Upgrade libxfont to version 1.5.4, 2.0.3 or higher.

Overview

Affected versions of this package are vulnerable to Symlink Attack. In libXfont before 1.5.4 and libXfont2 before 2.0.3, a local attacker can open (but not read) files on the system as root, triggering tape rewinds, watchdogs, or similar mechanisms that can be triggered by opening files.

CVSS Base Scores

version 3.1