Out-of-Bounds Affecting libxi package, versions [,1.7.2)


Severity

Recommended
0.0
medium
0
10

CVSS assessment by Snyk's Security Team. Learn more

Threat Intelligence

EPSS
1.88% (77th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications

Snyk Learn

Learn about Out-of-Bounds vulnerabilities in an interactive lesson.

Start learning
  • Snyk IDSNYK-UNMANAGED-LIBXI-2371850
  • published26 Jan 2022
  • disclosed15 Jun 2013
  • creditUnknown

Introduced: 15 Jun 2013

CVE-2013-1995  (opens in a new tab)
CWE-119  (opens in a new tab)

How to fix?

Upgrade libxi to version 1.7.2 or higher.

Overview

Affected versions of this package are vulnerable to Out-of-Bounds. X.org libXi 1.7.1 and earlier allows X servers to trigger allocation of insufficient memory and a buffer overflow via vectors related to an unexpected sign extension in the XListInputDevices function.

References

CVSS Base Scores

version 3.1