Out-of-Bounds Affecting libxi package, versions [,1.7.2)


Severity

Recommended
0.0
medium
0
10

CVSS assessment by Snyk's Security Team. Learn more

Threat Intelligence

EPSS
2.8% (85th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications

Snyk Learn

Learn about Out-of-Bounds vulnerabilities in an interactive lesson.

Start learning
  • Snyk IDSNYK-UNMANAGED-LIBXI-2371851
  • published26 Jan 2022
  • disclosed15 Jun 2013
  • creditUnknown

Introduced: 15 Jun 2013

CVE-2013-1998  (opens in a new tab)
CWE-119  (opens in a new tab)

How to fix?

Upgrade libxi to version 1.7.2 or higher.

Overview

Affected versions of this package are vulnerable to Out-of-Bounds. Multiple buffer overflows in X.org libXi 1.7.1 and earlier allow X servers to cause a denial of service (crash) and possibly execute arbitrary code via crafted length or index values to the (1) XGetDeviceButtonMapping, (2) XIPassiveGrabDevice, and (3) XQueryDeviceState functions.

References

CVSS Base Scores

version 3.1