Improper Access Control Affecting libxi package, versions [0,1.7.7)


Severity

Recommended
0.0
high
0
10

CVSS assessment by Snyk's Security Team. Learn more

Threat Intelligence

EPSS
3.01% (87th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications

Snyk Learn

Learn about Improper Access Control vulnerabilities in an interactive lesson.

Start learning
  • Snyk IDSNYK-UNMANAGED-LIBXI-2371852
  • published26 Jan 2022
  • disclosed13 Dec 2016
  • creditUnknown

Introduced: 13 Dec 2016

CVE-2016-7946  (opens in a new tab)
CWE-284  (opens in a new tab)

How to fix?

Upgrade libxi to version 1.7.7 or higher.

Overview

Affected versions of this package are vulnerable to Improper Access Control. X.org libXi before 1.7.7 allows remote X servers to cause a denial of service (infinite loop) via vectors involving length fields.

References

CVSS Base Scores

version 3.1