Out-of-Bounds Affecting libxvmc package, versions [,1.0.8)


Severity

Recommended
0.0
medium
0
10

CVSS assessment by Snyk's Security Team. Learn more

Threat Intelligence

EPSS
2.33% (82nd percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications

Snyk Learn

Learn about Out-of-Bounds vulnerabilities in an interactive lesson.

Start learning
  • Snyk IDSNYK-UNMANAGED-LIBXVMC-2395799
  • published26 Jan 2022
  • disclosed15 Jun 2013
  • creditUnknown

Introduced: 15 Jun 2013

CVE-2013-1999  (opens in a new tab)
CWE-119  (opens in a new tab)

How to fix?

Upgrade libxvmc to version 1.0.8 or higher.

Overview

Affected versions of this package are vulnerable to Out-of-Bounds. Buffer overflow in X.org libXvMC 1.0.7 and earlier allows X servers to cause a denial of service (crash) and possibly execute arbitrary code via crafted length or index values to the XvMCGetDRInfo function.

References

CVSS Base Scores

version 3.1