Out-of-Bounds Affecting libxvmc package, versions [,1.0.10)


Severity

Recommended
0.0
critical
0
10

CVSS assessment by Snyk's Security Team. Learn more

Threat Intelligence

EPSS
3.45% (89th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications

Snyk Learn

Learn about Out-of-Bounds vulnerabilities in an interactive lesson.

Start learning
  • Snyk IDSNYK-UNMANAGED-LIBXVMC-2395801
  • published26 Jan 2022
  • disclosed13 Dec 2016
  • creditUnknown

Introduced: 13 Dec 2016

CVE-2016-7953  (opens in a new tab)
CWE-119  (opens in a new tab)

How to fix?

Upgrade libxvmc to version 1.0.10 or higher.

Overview

Affected versions of this package are vulnerable to Out-of-Bounds. Buffer underflow in X.org libXvMC before 1.0.10 allows remote X servers to have unspecified impact via an empty string.

References

CVSS Base Scores

version 3.1