Out-of-bounds Read Affecting lua package, versions [5.4.0,5.4.1)


Severity

Recommended
0.0
critical
0
10

CVSS assessment by Snyk's Security Team. Learn more

Threat Intelligence

EPSS
2.23% (81st percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications

Snyk Learn

Learn about Out-of-bounds Read vulnerabilities in an interactive lesson.

Start learning
  • Snyk IDSNYK-UNMANAGED-LUA-2319489
  • published14 Dec 2021
  • disclosed21 Jul 2020
  • creditUnknown

Introduced: 21 Jul 2020

CVE-2020-15889  (opens in a new tab)
CWE-125  (opens in a new tab)

How to fix?

Upgrade lua to version 5.4.1 or higher.

Overview

Affected versions of this package are vulnerable to Out-of-bounds Read. Lua 5.4.0 has a getobjname heap-based buffer over-read because youngcollection in lgc.c uses markold for an insufficient number of list members.

CVSS Base Scores

version 3.1