Integer Underflow Affecting lua package, versions [0,5.4.1)


Severity

Recommended
0.0
medium
0
10

CVSS assessment by Snyk's Security Team. Learn more

Threat Intelligence

Exploit Maturity
Proof of Concept
EPSS
3.83% (89th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-UNMANAGED-LUA-2319495
  • published14 Dec 2021
  • disclosed17 Aug 2020
  • creditUnknown

Introduced: 17 Aug 2020

CVE-2020-24370  (opens in a new tab)
CWE-191  (opens in a new tab)

How to fix?

Upgrade lua to version 5.4.1 or higher.

Overview

Affected versions of this package are vulnerable to Integer Underflow ldebug.c in Lua 5.4.0 allows a negation overflow and segmentation fault in getlocal and setlocal, as demonstrated by getlocal(3,2^31).

CVSS Base Scores

version 3.1