Arbitrary Code Execution Affecting mongodb-js/kerberos package, versions [,1.0.0)


Severity

Recommended
0.0
high
0
10

CVSS assessment by Snyk's Security Team. Learn more

Threat Intelligence

Exploit Maturity
Proof of Concept
EPSS
0.74% (50th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-UNMANAGED-MONGODBJSKERBEROS-2370595
  • published26 Jan 2022
  • disclosed16 May 2020
  • creditUnknown

Introduced: 16 May 2020

CVE-2020-13110  (opens in a new tab)
CWE-427  (opens in a new tab)

How to fix?

Upgrade mongodb-js/kerberos to version 1.0.0 or higher.

Overview

Affected versions of this package are vulnerable to Arbitrary Code Execution. The kerberos package before 1.0.0 for Node.js allows arbitrary code execution and privilege escalation via injection of malicious DLLs through use of the kerberos_sspi LoadLibrary() method, because of a DLL path search.

References

CVSS Base Scores

version 3.1