Cross-site Request Forgery (CSRF) Affecting monit package, versions [,5.20.0)


Severity

Recommended
0.0
medium
0
10

CVSS assessment by Snyk's Security Team. Learn more

Threat Intelligence

EPSS
0.88% (58th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-UNMANAGED-MONIT-2374208
  • published26 Jan 2022
  • disclosed10 Sept 2018
  • creditUnknown

Introduced: 10 Sep 2018

CVE-2016-7067  (opens in a new tab)
CWE-352  (opens in a new tab)

How to fix?

Upgrade monit to version 5.20.0 or higher.

Overview

Affected versions of this package are vulnerable to Cross-site Request Forgery (CSRF). Monit before version 5.20.0 is vulnerable to a cross site request forgery attack. Successful exploitation will enable an attacker to disable/enable all monitoring for a particular host or disable/enable monitoring for a specific service.

References

CVSS Base Scores

version 3.1