HTTP Request Smuggling Affecting mopemope/meinheld package, versions [,1.0.2)


Severity

Recommended
0.0
medium
0
10

CVSS assessment by Snyk's Security Team. Learn more

Threat Intelligence

Exploit Maturity
Proof of Concept
EPSS
0.69% (48th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-UNMANAGED-MOPEMOPEMEINHELD-2371748
  • published26 Jan 2022
  • disclosed22 May 2020
  • creditUnknown

Introduced: 22 May 2020

CVE-2020-7658  (opens in a new tab)
CWE-444  (opens in a new tab)

How to fix?

Upgrade mopemope/meinheld to version 1.0.2 or higher.

Overview

Affected versions of this package are vulnerable to HTTP Request Smuggling meinheld prior to 1.0.2 is vulnerable to HTTP Request Smuggling. HTTP pipelining issues and request smuggling attacks might be possible due to incorrect Content-Length and Transfer encoding header parsing.

References

CVSS Base Scores

version 3.1