Out-of-Bounds Affecting mruby/mruby package, versions [,2.0.0)


Severity

Recommended
0.0
high
0
10

CVSS assessment by Snyk's Security Team. Learn more

Threat Intelligence

EPSS
1.49% (74th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications

Snyk Learn

Learn about Out-of-Bounds vulnerabilities in an interactive lesson.

Start learning
  • Snyk IDSNYK-UNMANAGED-MRUBYMRUBY-2333613
  • published12 Jan 2022
  • disclosed12 Jun 2018
  • creditUnknown

Introduced: 12 Jun 2018

CVE-2018-12248  (opens in a new tab)
CWE-119  (opens in a new tab)

How to fix?

Upgrade mruby/mruby to version 2.0.0 or higher.

Overview

Affected versions of this package are vulnerable to Out-of-Bounds. An issue was discovered in mruby 1.4.1. There is a heap-based buffer over-read associated with OP_ENTER because mrbgems/mruby-fiber/src/fiber.c does not extend the stack in cases of many arguments to fiber.

CVSS Base Scores

version 3.1