Command Injection Affecting network_manager_vpnc package, versions [,1.2.6)


Severity

Recommended
0.0
high
0
10

CVSS assessment by Snyk's Security Team. Learn more

Threat Intelligence

Exploit Maturity
Proof of Concept
EPSS
3.93% (90th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-UNMANAGED-NETWORKMANAGERVPNC-2381891
  • published26 Jan 2022
  • disclosed26 Jul 2018
  • creditUnknown

Introduced: 26 Jul 2018

CVE-2018-10900  (opens in a new tab)
CWE-78  (opens in a new tab)

How to fix?

Upgrade network_manager_vpnc to version 1.2.6 or higher.

Overview

Affected versions of this package are vulnerable to Command Injection. Network Manager VPNC plugin (aka networkmanager-vpnc) before version 1.2.6 is vulnerable to a privilege escalation attack. A new line character can be used to inject a Password helper parameter into the configuration data passed to VPNC, allowing an attacker to execute arbitrary commands as root.

CVSS Base Scores

version 3.1