Information Exposure Affecting nfs package, versions [,1.2.8)


Severity

Recommended
0.0
medium
0
10

CVSS assessment by Snyk's Security Team. Learn more

Threat Intelligence

EPSS
1.14% (67th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-UNMANAGED-NFS-2380319
  • published26 Jan 2022
  • disclosed21 Jan 2014
  • creditUnknown

Introduced: 21 Jan 2014

CVE-2013-1923  (opens in a new tab)
CWE-200  (opens in a new tab)

How to fix?

Upgrade nfs to version 1.2.8 or higher.

Overview

Affected versions of this package are vulnerable to Information Exposure rpc-gssd in nfs-utils before 1.2.8 performs reverse DNS resolution for server names during GSSAPI authentication, which might allow remote attackers to read otherwise-restricted files via DNS spoofing attacks.

CVSS Base Scores

version 3.1