Denial of Service (DoS) Affecting nfs package, versions [,1.0.6)


Severity

Recommended
0.0
medium
0
10

CVSS assessment by Snyk's Security Team. Learn more

Threat Intelligence

EPSS
1.73% (75th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-UNMANAGED-NFS-2380324
  • published26 Jan 2022
  • disclosed14 Jun 2004
  • creditUnknown

Introduced: 14 Jun 2004

CVE-2004-0154  (opens in a new tab)
CWE-400  (opens in a new tab)

How to fix?

Upgrade nfs to version 1.0.6 or higher.

Overview

Affected versions of this package are vulnerable to Denial of Service (DoS) rpc.mountd in nfs-utils after 1.0.3 and before 1.0.6 allows attackers to cause a denial of service (crash) via an NFS mount of a directory from a client whose reverse DNS lookup name is different from the forward lookup name.

References

CVSS Base Scores

version 3.1