HTTP Request Smuggling Affecting ohler55/agoo package, versions [,2.14.0)


Severity

Recommended
0.0
high
0
10

CVSS assessment by Snyk's Security Team. Learn more

Threat Intelligence

Exploit Maturity
Proof of Concept
EPSS
1.17% (64th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-UNMANAGED-OHLER55AGOO-2368649
  • published26 Jan 2022
  • disclosed10 Jun 2020
  • creditUnknown

Introduced: 10 Jun 2020

CVE-2020-7670  (opens in a new tab)
CWE-444  (opens in a new tab)

How to fix?

Upgrade ohler55/agoo to version 2.14.0 or higher.

Overview

Affected versions of this package are vulnerable to HTTP Request Smuggling agoo prior to 2.14.0 allows request smuggling attacks where agoo is used as a backend and a frontend proxy also being vulnerable. HTTP pipelining issues and request smuggling attacks might be possible due to incorrect Content-Length and Transfer encoding header parsing. It is possible to conduct HTTP request smuggling attacks where agoo is used as part of a chain of backend servers due to insufficient Content-Length and Transfer Encoding parsing.

CVSS Base Scores

version 3.1