Out-of-Bounds Affecting ohler55/ox package, versions [,2.8.2)


Severity

Recommended
0.0
medium
0
10

CVSS assessment by Snyk's Security Team. Learn more

Threat Intelligence

EPSS
0.97% (61st percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications

Snyk Learn

Learn about Out-of-Bounds vulnerabilities in an interactive lesson.

Start learning
  • Snyk IDSNYK-UNMANAGED-OHLER55OX-2368652
  • published26 Jan 2022
  • disclosed26 Feb 2018
  • creditUnknown

Introduced: 26 Feb 2018

CVE-2017-16229  (opens in a new tab)
CWE-119  (opens in a new tab)

How to fix?

Upgrade ohler55/ox to version 2.8.2 or higher.

Overview

Affected versions of this package are vulnerable to Out-of-Bounds. In the Ox gem 2.8.1 for Ruby, the process crashes with a stack-based buffer over-read in the read_from_str function in sax_buf.c when a crafted input is supplied to sax_parse.

References

CVSS Base Scores

version 3.1