Improper Input Validation Affecting ohler55/ox package, versions [,2.8.1)


Severity

Recommended
0.0
high
0
10

CVSS assessment by Snyk's Security Team. Learn more

Threat Intelligence

EPSS
1.71% (77th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-UNMANAGED-OHLER55OX-2368653
  • published26 Jan 2022
  • disclosed27 Oct 2017
  • creditUnknown

Introduced: 27 Oct 2017

CVE-2017-15928  (opens in a new tab)
CWE-20  (opens in a new tab)

How to fix?

Upgrade ohler55/ox to version 2.8.1 or higher.

Overview

Affected versions of this package are vulnerable to Improper Input Validation. In the Ox gem 2.8.0 for Ruby, the process crashes with a segmentation fault when a crafted input is supplied to parse_obj. NOTE: the vendor has stated "Ox should handle the error more gracefully" but has not confirmed a security implication.

CVSS Base Scores

version 3.1