Improper Input Validation Affecting openconnect package, versions [,8.9)


Severity

Recommended
0.0
medium
0
10

CVSS assessment by Snyk's Security Team. Learn more

Threat Intelligence

EPSS
1.74% (77th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-UNMANAGED-OPENCONNECT-2366708
  • published26 Jan 2022
  • disclosed23 Apr 2020
  • creditUnknown

Introduced: 23 Apr 2020

CVE-2020-12105  (opens in a new tab)
CWE-20  (opens in a new tab)

How to fix?

Upgrade openconnect to version 8.9 or higher.

Overview

Affected versions of this package are vulnerable to Improper Input Validation. OpenConnect through 8.08 mishandles negative return values from X509_check_ function calls, which might assist attackers in performing man-in-the-middle attacks.

References

CVSS Base Scores

version 3.1