Out-of-bounds Write Affecting opencv/opencv package, versions [,2.4.13.6)[3.0.0-alpha,3.4.1)


Severity

Recommended
0.0
medium
0
10

CVSS assessment by Snyk's Security Team. Learn more

Threat Intelligence

EPSS
1.52% (73rd percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications

Snyk Learn

Learn about Out-of-bounds Write vulnerabilities in an interactive lesson.

Start learning
  • Snyk IDSNYK-UNMANAGED-OPENCVOPENCV-2369578
  • published26 Jan 2022
  • disclosed8 Jan 2018
  • creditUnknown

Introduced: 8 Jan 2018

CVE-2018-5268  (opens in a new tab)
CWE-787  (opens in a new tab)

How to fix?

Upgrade opencv/opencv to version 2.4.13.6, 3.4.1 or higher.

Overview

Affected versions of this package are vulnerable to Out-of-bounds Write. In OpenCV 3.3.1, a heap-based buffer overflow happens in cv::Jpeg2KDecoder::readComponent8u in modules/imgcodecs/src/grfmt_jpeg2000.cpp when parsing a crafted image file.

References

CVSS Base Scores

version 3.1