Improper Input Validation Affecting opencv/opencv package, versions [,2.4.13.4)[3.0.0-alpha,3.3.1)


Severity

Recommended
0.0
medium
0
10

CVSS assessment by Snyk's Security Team. Learn more

Threat Intelligence

EPSS
1.08% (65th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-UNMANAGED-OPENCVOPENCV-2369582
  • published26 Jan 2022
  • disclosed10 Apr 2017
  • creditUnknown

Introduced: 10 Apr 2017

CVE-2016-1517  (opens in a new tab)
CWE-20  (opens in a new tab)

How to fix?

Upgrade opencv/opencv to version 2.4.13.4, 3.3.1 or higher.

Overview

Affected versions of this package are vulnerable to Improper Input Validation. OpenCV 3.0.0 allows remote attackers to cause a denial of service (segfault) via vectors involving corrupt chunks.

References

CVSS Base Scores

version 3.1