Out-of-bounds Write Affecting pspp package, versions [,1.4.0)


Severity

Recommended
0.0
high
0
10

CVSS assessment by Snyk's Security Team. Learn more

Threat Intelligence

EPSS
0.81% (56th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications

Snyk Learn

Learn about Out-of-bounds Write vulnerabilities in an interactive lesson.

Start learning
  • Snyk IDSNYK-UNMANAGED-PSPP-2383236
  • published26 Jan 2022
  • disclosed19 Dec 2018
  • creditUnknown

Introduced: 19 Dec 2018

CVE-2018-20230  (opens in a new tab)
CWE-787  (opens in a new tab)

How to fix?

Upgrade pspp to version 1.4.0 or higher.

Overview

Affected versions of this package are vulnerable to Out-of-bounds Write. An issue was discovered in PSPP 1.2.0. There is a heap-based buffer overflow at the function read_bytes_internal in utilities/pspp-dump-sav.c, which allows attackers to cause a denial of service (application crash) or possibly have unspecified other impact.

CVSS Base Scores

version 3.1