Improper Input Validation Affecting qpdf/qpdf package, versions [,7.0.0)


Severity

Recommended
0.0
high
0
10

CVSS assessment by Snyk's Security Team. Learn more

Threat Intelligence

EPSS
1.8% (78th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-UNMANAGED-QPDFQPDF-2369470
  • published26 Jan 2022
  • disclosed27 Aug 2017
  • creditUnknown

Introduced: 27 Aug 2017

CVE-2017-12595  (opens in a new tab)
CWE-20  (opens in a new tab)

How to fix?

Upgrade qpdf/qpdf to version 7.0.0 or higher.

Overview

Affected versions of this package are vulnerable to Improper Input Validation. The tokenizer in QPDF 6.0.0 and 7.0.b1 is recursive for arrays and dictionaries, which allows remote attackers to cause a denial of service (stack consumption and segmentation fault) or possibly have unspecified other impact via a PDF document with a deep data structure, as demonstrated by a crash in QPDFObjectHandle::parseInternal in libqpdf/QPDFObjectHandle.cc.

CVSS Base Scores

version 3.1