Improper Input Validation Affecting quagga/quagga package, versions [,0.99.1)


Severity

Recommended
0.0
medium
0
10

CVSS assessment by Snyk's Security Team. Learn more

Threat Intelligence

EPSS
1.74% (75th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-UNMANAGED-QUAGGAQUAGGA-2374155
  • published26 Jan 2022
  • disclosed12 Apr 2007
  • creditUnknown

Introduced: 12 Apr 2007

CVE-2007-1995  (opens in a new tab)
CWE-20  (opens in a new tab)

How to fix?

Upgrade quagga/quagga to version 0.99.1 or higher.

Overview

Affected versions of this package are vulnerable to Improper Input Validation bgpd/bgp_attr.c in Quagga 0.98.6 and earlier, and 0.99.6 and earlier 0.99 versions, does not validate length values in the MP_REACH_NLRI and MP_UNREACH_NLRI attributes, which allows remote attackers to cause a denial of service (daemon crash or exit) via crafted UPDATE messages that trigger an assertion error or out of bounds read.

References

CVSS Base Scores

version 3.1