Resource Management Errors Affecting quassel/quassel package, versions [,0.12)


Severity

Recommended
0.0
medium
0
10

CVSS assessment by Snyk's Security Team. Learn more

Threat Intelligence

EPSS
2.63% (84th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-UNMANAGED-QUASSELQUASSEL-2365805
  • published26 Jan 2022
  • disclosed10 Apr 2015
  • creditUnknown

Introduced: 10 Apr 2015

CVE-2015-2778  (opens in a new tab)
CWE-399  (opens in a new tab)

How to fix?

Upgrade quassel/quassel to version 0.12 or higher.

Overview

Affected versions of this package are vulnerable to Resource Management Errors. Quassel before 0.12-rc1 uses an incorrect data-type size when splitting a message, which allows remote attackers to cause a denial of service (crash) via a long CTCP query containing only multibyte characters.

References

CVSS Base Scores

version 3.1