SQL Injection Affecting quassel/quassel package, versions [,0.12.2)


Severity

Recommended
0.0
high
0
10

CVSS assessment by Snyk's Security Team. Learn more

Threat Intelligence

EPSS
1.99% (80th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications

Snyk Learn

Learn about SQL Injection vulnerabilities in an interactive lesson.

Start learning
  • Snyk IDSNYK-UNMANAGED-QUASSELQUASSEL-2365809
  • published26 Jan 2022
  • disclosed14 May 2015
  • creditUnknown

Introduced: 14 May 2015

CVE-2015-3427  (opens in a new tab)
CWE-89  (opens in a new tab)

How to fix?

Upgrade quassel/quassel to version 0.12.2 or higher.

Overview

Affected versions of this package are vulnerable to SQL Injection. Quassel before 0.12.2 does not properly re-initialize the database session when the PostgreSQL database is restarted, which allows remote attackers to conduct SQL injection attacks via a \ (backslash) in a message. NOTE: this vulnerability exists because of an incomplete fix for CVE-2013-4422.

References

CVSS Base Scores

version 3.1