Access Restriction Bypass Affecting radsecproxy/radsecproxy package, versions [,1.6.1)


Severity

Recommended
0.0
medium
0
10

CVSS assessment by Snyk's Security Team. Learn more

Threat Intelligence

EPSS
1.76% (76th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-UNMANAGED-RADSECPROXYRADSECPROXY-2370612
  • published26 Jan 2022
  • disclosed20 Nov 2012
  • creditUnknown

Introduced: 20 Nov 2012

CVE-2012-4523  (opens in a new tab)
CWE-264  (opens in a new tab)

How to fix?

Upgrade radsecproxy/radsecproxy to version 1.6.1 or higher.

Overview

Affected versions of this package are vulnerable to Access Restriction Bypass radsecproxy before 1.6.1 does not properly verify certificates when there are configuration blocks with CA settings that are unrelated to the block being used for verifying the certificate chain, which might allow remote attackers to bypass intended access restrictions and spoof clients.

References

CVSS Base Scores

version 3.1