Access Restriction Bypass Affecting rssh package, versions [,2.3.3)


Severity

Recommended
0.0
medium
0
10

CVSS assessment by Snyk's Security Team. Learn more

Threat Intelligence

EPSS
0.39% (31st percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-UNMANAGED-RSSH-2380710
  • published26 Jan 2022
  • disclosed31 Aug 2012
  • creditUnknown

Introduced: 31 Aug 2012

CVE-2012-3478  (opens in a new tab)
CWE-264  (opens in a new tab)

How to fix?

Upgrade rssh to version 2.3.3 or higher.

Overview

Affected versions of this package are vulnerable to Access Restriction Bypass rssh 2.3.3 and earlier allows local users to bypass intended restricted shell access via crafted environment variables in the command line.

References

CVSS Base Scores

version 3.1