Out-of-bounds Write Affecting rsyslog/librelp package, versions [0,1.2.15)


Severity

Recommended
0.0
critical
0
10

CVSS assessment by Snyk's Security Team. Learn more

Threat Intelligence

EPSS
9.34% (96th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications

Snyk Learn

Learn about Out-of-bounds Write vulnerabilities in an interactive lesson.

Start learning
  • Snyk IDSNYK-UNMANAGED-RSYSLOGLIBRELP-2364696
  • published26 Jan 2022
  • disclosed23 Mar 2018
  • creditUnknown

Introduced: 23 Mar 2018

CVE-2018-1000140  (opens in a new tab)
CWE-787  (opens in a new tab)

How to fix?

Upgrade rsyslog/librelp to version 1.2.15 or higher.

Overview

Affected versions of this package are vulnerable to Out-of-bounds Write rsyslog librelp version 1.2.14 and earlier contains a Buffer Overflow vulnerability in the checking of x509 certificates from a peer that can result in Remote code execution. This attack appear to be exploitable a remote attacker that can connect to rsyslog and trigger a stack buffer overflow by sending a specially crafted x509 certificate.

References

CVSS Base Scores

version 3.1