Out-of-bounds Read Affecting sass/libsass package, versions [,3.6.3)


Severity

Recommended
0.0
medium
0
10

CVSS assessment by Snyk's Security Team. Learn more

Threat Intelligence

EPSS
1.05% (60th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications

Snyk Learn

Learn about Out-of-bounds Read vulnerabilities in an interactive lesson.

Start learning
  • Snyk IDSNYK-UNMANAGED-SASSLIBSASS-2364479
  • published26 Jan 2022
  • disclosed6 Nov 2019
  • creditUnknown

Introduced: 6 Nov 2019

CVE-2019-18798  (opens in a new tab)
CWE-125  (opens in a new tab)

How to fix?

Upgrade sass/libsass to version 3.6.3 or higher.

Overview

Affected versions of this package are vulnerable to Out-of-bounds Read. LibSass before 3.6.3 allows a heap-based buffer over-read in Sass::weaveParents in ast_sel_weave.cpp.

References

CVSS Base Scores

version 3.1