Directory Traversal Affecting sigil-ebook/flightcrew package, versions [,0.9.16)


Severity

Recommended
0.0
high
0
10

CVSS assessment by Snyk's Security Team. Learn more

Threat Intelligence

EPSS
3.69% (90th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications

Snyk Learn

Learn about Directory Traversal vulnerabilities in an interactive lesson.

Start learning
  • Snyk IDSNYK-UNMANAGED-SIGILEBOOKFLIGHTCREW-2366548
  • published26 Jan 2022
  • disclosed31 Jul 2019
  • creditUnknown

Introduced: 31 Jul 2019

CVE-2019-14452  (opens in a new tab)
CWE-22  (opens in a new tab)

How to fix?

Upgrade sigil-ebook/flightcrew to version 0.9.16 or higher.

Overview

Affected versions of this package are vulnerable to Directory Traversal. Sigil before 0.9.16 is vulnerable to a directory traversal, allowing attackers to write arbitrary files via a ../ (dot dot slash) in a ZIP archive entry that is mishandled during extraction.

CVSS Base Scores

version 3.1