Denial of Service (DoS) Affecting stunnel package, versions [,3.25)[4.00,4.04)


Severity

Recommended
0.0
low
0
10

CVSS assessment by Snyk's Security Team. Learn more

Threat Intelligence

EPSS
0.34% (26th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-UNMANAGED-STUNNEL-2370297
  • published26 Jan 2022
  • disclosed12 May 2003
  • creditUnknown

Introduced: 12 May 2003

CVE-2002-1563  (opens in a new tab)
CWE-400  (opens in a new tab)

How to fix?

Upgrade stunnel to version 3.25, 4.04 or higher.

Overview

Affected versions of this package are vulnerable to Denial of Service (DoS) stunnel 4.0.3 and earlier allows attackers to cause a denial of service (crash) via SIGCHLD signal handler race conditions that cause an inconsistency in the child counter.

References

CVSS Base Scores

version 3.1