File Descriptor Leak Affecting stunnel package, versions [,3.26)[4.00,4.04)


Severity

Recommended
0.0
medium
0
10

CVSS assessment by Snyk's Security Team. Learn more

Threat Intelligence

EPSS
0.7% (49th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-UNMANAGED-STUNNEL-2370301
  • published26 Jan 2022
  • disclosed20 Oct 2003
  • creditUnknown

Introduced: 20 Oct 2003

CVE-2003-0740  (opens in a new tab)
CWE-403  (opens in a new tab)

How to fix?

Upgrade stunnel to version 3.26, 4.04 or higher.

Overview

Affected versions of this package are vulnerable to File Descriptor Leak. Stunnel 4.00, and 3.24 and earlier, leaks a privileged file descriptor returned by listen(), which allows local users to hijack the Stunnel server.

CVSS Base Scores

version 3.1