Information Exposure Affecting sylabs/singularity package, versions [2.3.0,2.5.2)


Severity

Recommended
0.0
medium
0
10

CVSS assessment by Snyk's Security Team. Learn more

Threat Intelligence

EPSS
1.47% (74th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-UNMANAGED-SYLABSSINGULARITY-2364203
  • published26 Jan 2022
  • disclosed5 Jul 2018
  • creditUnknown

Introduced: 5 Jul 2018

CVE-2018-12021  (opens in a new tab)
CWE-200  (opens in a new tab)

How to fix?

Upgrade sylabs/singularity to version 2.5.2 or higher.

Overview

Affected versions of this package are vulnerable to Information Exposure. Singularity 2.3.0 through 2.5.1 is affected by an incorrect access control on systems supporting overlay file system. When using the overlay option, a malicious user may access sensitive information by exploiting a few specific Singularity features.

References

CVSS Base Scores

version 3.1