Improper Validation Affecting sylabs/singularity package, versions [3.0.0,3.5.1)


Severity

Recommended
0.0
high
0
10

CVSS assessment by Snyk's Security Team. Learn more

Threat Intelligence

EPSS
0.63% (46th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-UNMANAGED-SYLABSSINGULARITY-2364207
  • published26 Jan 2022
  • disclosed14 Jul 2020
  • creditUnknown

Introduced: 14 Jul 2020

CVE-2020-13847  (opens in a new tab)
CWE-354  (opens in a new tab)

How to fix?

Upgrade sylabs/singularity to version 3.5.1 or higher.

Overview

Affected versions of this package are vulnerable to Improper Validation. Sylabs Singularity 3.0 through 3.5 lacks support for an Integrity Check. Singularity's sign and verify commands do not sign metadata found in the global header or data object descriptors of a SIF file.

References

CVSS Base Scores

version 3.1