Improper Input Validation Affecting sylabs/singularity package, versions [2.4,2.6.1)


Severity

Recommended
0.0
high
0
10

CVSS assessment by Snyk's Security Team. Learn more

Threat Intelligence

EPSS
0.47% (40th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-UNMANAGED-SYLABSSINGULARITY-2364209
  • published26 Jan 2022
  • disclosed17 Dec 2018
  • creditUnknown

Introduced: 17 Dec 2018

CVE-2018-19295  (opens in a new tab)
CWE-20  (opens in a new tab)

How to fix?

Upgrade sylabs/singularity to version 2.6.1 or higher.

Overview

Affected versions of this package are vulnerable to Improper Input Validation. Sylabs Singularity 2.4 to 2.6 allows local users to conduct Improper Input Validation attacks.

CVSS Base Scores

version 3.1