Improper Input Validation Affecting teeworlds package, versions [,0.6.5)


Severity

Recommended
0.0
high
0
10

CVSS assessment by Snyk's Security Team. Learn more

Threat Intelligence

EPSS
2.94% (87th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-UNMANAGED-TEEWORLDS-2371982
  • published26 Jan 2022
  • disclosed20 Oct 2018
  • creditUnknown

Introduced: 20 Oct 2018

CVE-2018-18541  (opens in a new tab)
CWE-20  (opens in a new tab)

How to fix?

Upgrade teeworlds to version 0.6.5 or higher.

Overview

Affected versions of this package are vulnerable to Improper Input Validation. In Teeworlds before 0.6.5, connection packets could be forged. There was no challenge-response involved in the connection build up. A remote attacker could send connection packets from a spoofed IP address and occupy all server slots, or even use them for a reflection attack using map download packets.

CVSS Base Scores

version 3.1