Improper Authentication Affecting tinc package, versions [,1.0.35)[1.1-pre1,1.1-pre17)


Severity

Recommended
0.0
medium
0
10

CVSS assessment by Snyk's Security Team. Learn more

Threat Intelligence

EPSS
1.47% (71st percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications

Snyk Learn

Learn about Improper Authentication vulnerabilities in an interactive lesson.

Start learning
  • Snyk IDSNYK-UNMANAGED-TINC-2370078
  • published26 Jan 2022
  • disclosed10 Oct 2018
  • creditUnknown

Introduced: 10 Oct 2018

CVE-2018-16737  (opens in a new tab)
CWE-287  (opens in a new tab)

How to fix?

Upgrade tinc to version 1.0.35, 1.1-pre17 or higher.

Overview

Affected versions of this package are vulnerable to Improper Authentication tinc before 1.0.30 has a broken authentication protocol, without even a partial mitigation.

References

CVSS Base Scores

version 3.1