Information Exposure Affecting tinyproxy/tinyproxy package, versions [0,]


0.0
medium

Snyk CVSS

    Exploit Maturity Proof of concept
    Attack Complexity Low
Expand this section
NVD
7.5 high

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk ID SNYK-UNMANAGED-TINYPROXYTINYPROXY-3027426
  • published 20 Sep 2022
  • disclosed 20 Sep 2022
  • credit yikesoftware

How to fix?

A fix was pushed into the master branch but not yet published.

Overview

Affected versions of this package are vulnerable to Information Exposure due to a lack of processing of the HTTP request lines in the process_request() function. Exploiting this vulnerability allows attackers to access sensitive information at system runtime.