Privilege Escalation Affecting torvalds/linux package, versions [,5.18-rc1)


0.0
high

Snyk CVSS

    Attack Complexity Low
    Confidentiality High
    Integrity High
    Availability High

    Threat Intelligence

    EPSS 0.04% (8th percentile)
Expand this section
NVD
7.8 high
Expand this section
Red Hat
7 high

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk ID SNYK-UNMANAGED-TORVALDSLINUX-5596912
  • published 24 May 2023
  • disclosed 11 May 2023
  • credit Adam Zabrocki

How to fix?

Upgrade torvalds/linux to version 5.18-rc1 or higher.

Overview

Affected versions of this package are vulnerable to Privilege Escalation due to an improper restriction of operations on a memory buffer in i915_gem_mman.c in the i915 graphics driver.