Out-of-bounds Write Affecting UnZip package, versions [0,6.1c23)


Severity

Recommended
0.0
high
0
10

CVSS assessment by Snyk's Security Team. Learn more

Threat Intelligence

EPSS
30.07% (99th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications

Snyk Learn

Learn about Out-of-bounds Write vulnerabilities in an interactive lesson.

Start learning
  • Snyk IDSNYK-UNMANAGED-UNZIP-2636635
  • published26 Jan 2022
  • disclosed9 Feb 2018
  • creditUnknown

Introduced: 9 Feb 2018

CVE-2018-1000035  (opens in a new tab)
CWE-787  (opens in a new tab)

How to fix?

Upgrade UnZip to version 6.1c23 or higher.

Overview

Affected versions of this package are vulnerable to Out-of-bounds Write. A heap-based buffer overflow exists in Info-Zip UnZip version <= 6.00 in the processing of password-protected archives that allows an attacker to perform a denial of service or to possibly achieve code execution.

References

CVSS Base Scores

version 3.1