Out-of-Bounds Affecting vala package, versions [0.26.0,0.27.1)


Severity

Recommended
0.0
high
0
10

CVSS assessment by Snyk's Security Team. Learn more

Threat Intelligence

EPSS
2.8% (85th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications

Snyk Learn

Learn about Out-of-Bounds vulnerabilities in an interactive lesson.

Start learning
  • Snyk IDSNYK-UNMANAGED-VALA-2374428
  • published26 Jan 2022
  • disclosed27 Jan 2015
  • creditUnknown

Introduced: 27 Jan 2015

CVE-2014-8154  (opens in a new tab)
CWE-119  (opens in a new tab)

How to fix?

Upgrade vala to version 0.27.1 or higher.

Overview

Affected versions of this package are vulnerable to Out-of-Bounds. The Gst.MapInfo function in Vala 0.26.0 and 0.26.1 uses an incorrect buffer length declaration for the Gstreamer bindings, which allows context-dependent attackers to cause a denial of service (crash) or possibly execute arbitrary code via unspecified vectors, which trigger a heap-based buffer overflow.

CVSS Base Scores

version 3.1