Use After Free Affecting vim/vim Open this link in a new tab package, versions [,8.2.4895)


0.0
medium
  • Attack Complexity

    Low

  • User Interaction

    Required

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • snyk-id

    SNYK-UNMANAGED-VIMVIM-2812529

  • published

    9 May 2022

  • disclosed

    7 May 2022

  • credit

    Muhammad Aldo Firmansyah

How to fix?

Upgrade vim/vim to version 8.2.4895 or higher.

Overview

Affected versions of this package are vulnerable to Use After Free in via the append_command of src/ex_docmd.c. Exploiting this vulnerability might result in software crashing, bypassing protection mechanisms, modifying memory, and possible remote execution.

References