Cross-site Scripting (XSS) Affecting vino package, versions [,2.99.5)


Severity

Recommended
0.0
medium
0
10

CVSS assessment by Snyk's Security Team. Learn more

Threat Intelligence

EPSS
1.63% (73rd percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-UNMANAGED-VINO-2408984
  • published26 Jan 2022
  • disclosed12 Mar 2013
  • creditUnknown

Introduced: 12 Mar 2013

CVE-2011-1164  (opens in a new tab)
CWE-16  (opens in a new tab)

How to fix?

Upgrade vino to version 2.99.5 or higher.

Overview

Affected versions of this package are vulnerable to Cross-site Scripting (XSS). Vino before 2.99.4 can connect external networks contrary to the statement in the vino-preferences dialog box, which might make it easier for remote attackers to perform attacks.

References

CVSS Base Scores

version 3.1