Buffer Overflow Affecting webkitgtk package, versions [,2.36.5)


0.0
high

Snyk CVSS

    Attack Complexity Low
    User Interaction Required
    Confidentiality High
    Integrity High
Expand this section
RHEL
8.1 high

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk ID SNYK-UNMANAGED-WEBKITGTK-3028179
  • published 21 Sep 2022
  • disclosed 12 Sep 2022
  • credit @real_as3617

How to fix?

Upgrade webkitgtk to version 2.36.5 or higher.

Overview

Affected versions of this package are vulnerable to Buffer Overflow due to UI spoofing while visiting a website that frames malicious content.