Improper Input Validation Affecting znc package, versions [,1.8.0)


Severity

Recommended
0.0
high
0
10

CVSS assessment by Snyk's Security Team. Learn more

Threat Intelligence

EPSS
4.05% (91st percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-UNMANAGED-ZNC-2367716
  • published26 Jan 2022
  • disclosed15 Jun 2019
  • creditUnknown

Introduced: 15 Jun 2019

CVE-2019-12816  (opens in a new tab)
CWE-20  (opens in a new tab)

How to fix?

Upgrade znc to version 1.8.0 or higher.

Overview

Affected versions of this package are vulnerable to Improper Input Validation. Modules.cpp in ZNC before 1.7.4-rc1 allows remote authenticated non-admin users to escalate privileges and execute arbitrary code by loading a module with a crafted name.

CVSS Base Scores

version 3.1