Improper Input Validation Affecting zsh-users/zsh package, versions [,5.5)


Severity

Recommended
0.0
high
0
10

CVSS assessment by Snyk's Security Team. Learn more

Threat Intelligence

EPSS
2.59% (85th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-UNMANAGED-ZSHUSERSZSH-2369452
  • published26 Jan 2022
  • disclosed27 Feb 2018
  • creditUnknown

Introduced: 27 Feb 2018

CVE-2018-7549  (opens in a new tab)
CWE-20  (opens in a new tab)

How to fix?

Upgrade zsh-users/zsh to version 5.5 or higher.

Overview

Affected versions of this package are vulnerable to Improper Input Validation. In params.c in zsh through 5.4.2, there is a crash during a copy of an empty hash table, as demonstrated by typeset -p.

CVSS Base Scores

version 3.1