Deserialization of Untrusted Data Affecting cassandra-5.0 package, versions <5.0.3-r2


Severity

Recommended
0.0
high
0
10

Snyk's Security Team recommends NVD's CVSS assessment. Learn more

Threat Intelligence

EPSS
3.41% (89th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-WOLFILATEST-CASSANDRA50-15376188
  • published4 Mar 2026
  • disclosed2 Oct 2022

Introduced: 2 Oct 2022

CVE-2022-42004  (opens in a new tab)
CWE-502  (opens in a new tab)

How to fix?

Upgrade Wolfi cassandra-5.0 to version 5.0.3-r2 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream cassandra-5.0 package and not the cassandra-5.0 package as distributed by Wolfi. See How to fix? for Wolfi relevant fixed versions and status.

In FasterXML jackson-databind before 2.13.4, resource exhaustion can occur because of a lack of a check in BeanDeserializer._deserializeFromArray to prevent use of deeply nested arrays. An application is vulnerable only with certain customized choices for deserialization.

CVSS Base Scores

version 3.1